Realtek-Network-Drivers
Llevo un tiempo sufriendo problemas de lectura en carpetas compartidas Samba (Windows) desde mi equipo Linux (ArchLinux).

Parece ser que el problema está en los drivers Realtek.

$ lspci -v

03:00.2 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 0a)
Subsystem: CLEVO/KAPOK Computer Device 0540
Flags: bus master, fast devsel, latency 0, IRQ 44
I/O ports at d000 [size=256]
Memory at f0a04000 (64-bit, prefetchable) [size=4K]
Memory at f0a00000 (64-bit, prefetchable) [size=16K]
Capabilities:
Kernel driver in use: r8169
Kernel modules: r8169

Para solucionarlo podemos instalar los drivers r8168 proporcionados por la comunidad y pondremos los drivers 8169 en las lista negra, tal y como sugiere la instalación de los nuevos drivers:

# pacman -S r8168
# echo "blacklist r8169" > /etc/modprobe.d/r8169_blacklist.conf

Reiniciamos, y listo.

NOTA: Si el problema persiste, o tenemos un kernel personalizado -como es mi caso-, podemos probar con el paquete r8168-all de AUR.

vía

Anuncios

Logo Lotus Notes
Antes de realizar la instalación habrá que instalar las dependencias previas según indico en la entrada IBM Notes 9.0 beta en Arch Linux (32 bits).

Una vez instaladas las dependencias basta con seguir los siguientes pasos:

  1. Descargamos el fichero sametime-setup-linux.zip de http://sametime.dpteruel.es/sametime/network-install/applet/index_en.html?lang=en (alternativamente podemos descargar el rpm o el deb de http://theweeks.org/tmp/FILES/ST-8.5.2_GA/Linux/)
  2. Lo descomprimimos (unzip) y obtenemos el paquete rpm.
  3. Lo instalamos ejecutando lo siguientes comandos:

    # export ST_BYPASS_CONFLICT_CHECK=true
    # rpm -ivh --nodeps sametime-connect-8.5.2-20110516.2011.i586.rpm

Y ya podemos ejecutar:

$ sametime-connect

Algunos enlaces de interés
How to download and install IBM Lotus Sametime Connect 8.5.2 on Ubuntu 13.04 64bit

KernelPuedes crear tu propio kernel PAE (y así tener acceso a más de 4GB de memoria en un kernel de 32bits) utilizando ABS:

$ sudo abs core/linux
$ mkdir -p ~/abs/core
$ cp -a /var/abs/core/linux ~/abs/core/linux-pae
$ cd ~/abs/core/linux-pae
$ sed -i "s/HIGHMEM4G/HIGHMEM64G/" config
$ sed -i "s/pkgbase=linux/pkgbase=linux-pae/" PKGBUILD
$ updpkgsums
$ sudo makepkg --asroot
$ makepkg

Acepta las opciones por defecto (de tal modo que el kernel que compiles sea lo más parecido al kernel “stock” de ArchLinux).

Instala tu nuevo kernel:

$ sudo pacman -U linux-pae-3.8.7-1-i686.pkg.tar.xz
$ sudo pacman -U linux-pae-headers-3.8.7-1-i686.pkg.tar.xz

Algunos enlaces de interés

linux-pae
Kernels/Compilation/Arch Build System

Notes9

  1. Descargar el paquete de instalación en formato rpm desde IBM (es necesario estar registrado):

    https://www14.software.ibm.com/webapp/iwm/web/reg/signup.do?source=swg-beta-nodoso&S_PKG=dl

  2. Instalar manualmente las dependencias no disponibles en el repositorio oficial pero sí en el AUR (también puedes usar Yaourt que realiza las instalaciones desde AUR de forma automática):

    $ wget https://aur.archlinux.org/packages/li/libgnomecups/libgnomecups.tar.gz
    $ tar -xvzf libgnomecups.tar.gz
    $ cd libgnomecups
    $ makepkg
    # pacman -U libgnomecups-0.2.3-12-i686.pkg.tar.xz

    $ wget https://aur.archlinux.org/packages/li/libgnomeprint/libgnomeprint.tar.gz
    $ tar -xvzf libgnomeprint.tar.gz
    $ cd libgnomeprint
    $ makepkg -s
    # pacman -U libgnomeprint-2.18.8-5-i686.pkg.tar.xz

    $ wget https://aur.archlinux.org/packages/li/libgnomeprintui/libgnomeprintui.tar.gz
    $ tar -xvzf libgnomeprintui.tar.gz
    $ cd libgnomeprintui
    $ makepkg -s
    # pacman -U libgnomeprintui-2.18.6-4-i686.pkg.tar.xz

  3. Instalar manualmente las dependencias disponibles en el repositorio oficial:

    # pacman -S --needed gdb coreutils unzip bash procps-ng grep sed libart-lgpl alsa-lib atk libbonobo libbonoboui glibc libcap fontconfig freetype2 gcc gconf gtk glib libgnome libgnomecanvas gnome-desktop libgnomeui gnome-vfs libice libjpeg-turbo orbit2 pam pango pangox-compat libpng popt libsm gcc libx11 libxcursor libxext libxft libxi libxkbfile libxml2 libxp libxrender xscreensaver libxt libxtst zlib xterm

  4. Descomprimir el paquete desacargado:

    tar -xvf notes90se_notes_linux_rpm_public_beta_prod.tar

  5. Intalar el gestor de paquete rpm desde AUR:

    $ wget https://aur.archlinux.org/packages/rp/rpm-org/rpm-org.tar.gz
    $ tar xvfz rpm-org.tar.gz
    $ cd rpm-org
    $ makepkg -s
    # pacman -U rpm-org-4.10.2-1-i686.pkg.tar.xz

  6. Ejecutar la instalación:
    # rpm -ivh --nodeps ibm_notes-9.0.i586.rpm
    # rpm -ivh --nodeps ibm_sametime-9.0.i586.rpm

Opcionalmente, si queremos añadir la comprobación de ortografía en Español haremos lo siguiente:

  1. Descargar el paquete de diccionarios de la versión 8.5.2 (aún no existe uno específico para la versión 9.0 y aunque ya existe una versión actualizada para 8.5.3 no he encontrado ningún enlace disponible para su descarga):

    http://h1898038.stratoserver.net/download/lotus/dictionaries/Notes_XTAFDictionaries_852_WinLnx_Ml.zip

    ACTUALIZACION:
    Alternativamente podemos descargar el diccionario español de Lotus Symphony (donde está disponible una versión más reciente) desde:
    http://www-03.ibm.com/software/lotus/symphony/home.nsf/dictionary

  2. Descomprimir el paquete descargado:

    unzip Notes_XTAFDictionaries_852_WinLnx_Ml.zip

    ACTUALIZACION:
    O, si te has bajado el diccionario de la página de Lotus Symphony:
    unzip sym.dic.es.zip

  3. Instalarlo en el cliente Notes como una actualización File –> Application –> Install, seleccionando el archivo adecuado, en nuestro caso updateSite_es.zip para el idioma castellano.

    ACTUALIZACION:
    O, si te has bajado el diccionario de la página de Lotus Symphony simplemente updateSite.zip.

  4. Reiniciar Lotus Notes
  5. Configurar el idioma de revisión de ortografía dentro de Notes y Sametime en Preferences –> Spell Check y en Preferences –> Sametime –> Spell Checking

NOTA: Si no os aparece la opción Install debéis activarla modificando (o añadiendo en caso de que no exista) el parámetro
com.ibm.notes.branding/enable.update.ui=true
en el archivo plugin_customizations.ini ubicado en el directorio notes/framework/rcp de la instalación de la aplicación.

ACTUALIZACION:
Si modificas el valor del parámetro:
com.ibm.notes.branding/enable.update.ui=true
en el archivo
/opt/ibm/notes/framework/rcp/plugin_customizations.ini
después de haber configurado tu correo, es posible que tu configuración no la tenga en cuenta.
Entonces tendremos que modificar la propiedad:
enable.update.ui=true
del archivo:
/home/rubensa/ibm/notes/data/workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.ibm.notes.branding.prefs

Dependiendo del plugin que vayamos a instalar, también es posible que tengas que cambiar “temporalmente” los permisos del directorio de instalación del Notes para que un usuario “no root” pueda instalar la actualización (ya que el cliente de notes no permite su ejecución como root). Antes de instalar ejecuta:
sudo chmod 777 -R /opt/ibm/notes/
y después:
sudo chmod 755 -R /opt/ibm/notes/

Alternativamente, antes de instalar el plugin, podemos editar el fichero feature.xml que se encuentra dentro del .jar ubicado en el directorio features del updateSite.zip modificando la propiedad:
<feature colocation-affinity="com.ibm.rcp.platform.feature"...
por:
<feature colocation-affinity="com.ibm.rcp.site.anchor.user.feature"...
de tal modo que hacemos que la instalación sea a nivel de usuario en vez de a nivel de aplicación.

Si hacemos este cambio tenemos que tener en cuenta que la firma del plugin ya no será válida y por tanto tendremos que eliminar los datos de la firma (META-INF) y permitir la instalación de plugins sin firmar (/home/rubensa/ibm/notes/data/workspace/.metadata/.plugins/org.eclipse.core.runtime/.settings/com.ibm.rcp.security.update.prefs).

NOTA 2: En Gnome Shell parace que la aplicación tiene problemas con algunos de los diálogos modales (se quedan “trabados” y no responden). Para solucionar el problema tenemos que deshabilitar la integración de diálogos modales en las ventanas padre ejecutando el siguiente comando (después hay que reiniciar Gnome – Alt+F2+r):

$ gsettings set org.gnome.shell.overrides attach-modal-dialogs false

Actualizar a 9.0.1
La versión 9.0.1 ya tiene soporte español. Para actualizar a la nueva versión, antes desinstalamos la versión previamente instalada. Podemos comprobar la versión utilizando el comando:
#rpm -qa

Procedemos con la desinstalación:
#rpm -e ibm_sametime-9.0
#rpm -e ibm_notes-9.0

Y con la instalación de los nuevos paquetes (incluyendo también los de idioma español)
#rpm -ivh --nodeps ibm_notes-9.0.1.i586.rpm
#rpm -ivh --nodeps ibm_notes-nl1-9.0.1.i586.rpm
#rpm -ivh --nodeps ibm_notes-core-es-9.0.1.i586.rpm

Algunos enlaces de interés

Lotus Notes in 32bit Chroot
AUR lotus-notes-base
Install plugins from updateSite in Lotus Notes on linux
Enabling user-initiated update with EUM
Enabling File – Application – Install for specific users
Customizing Notes using a plugin_customization.ini file

A %d blogueros les gusta esto: